Site announcements

All Users: Chrome or Firefox browsers recommended for Moodle courses

All Users: Chrome or Firefox browsers recommended for Moodle courses

by Nancy Chan -
Number of replies: 0

Due to various problems related to access and functionality with Moodle, Panopto, or VoiceThread, we do not recommend Safari when accessing and interacting with these platforms.

We recommend using Firefox or Chrome for the best results.

If you find that you are still having log-in issues or errors with Firefox or Chrome, third-party cookies are often required with these platforms in order to validate your login.

Questions? Contact us at Help Desk!